Degraded Performance on File Delivery
Incident Report for RATELIMITED
Resolved
We have issued a fix for the problem, and have monitored the results in the past two hours.
Posted 7 months ago. Feb 24, 2019 - 19:36 UTC
Investigating
We are seeing higher latency while doing file delivery, both while embedding, but also when directly visiting the page.

We are currently investigating this issue.

Uploads seem to be unaffected.
Posted 7 months ago. Feb 24, 2019 - 17:50 UTC
This incident affected: Service Functions (File Delivery).